WSL and Snap/Flatpak

I’ve been using Windows Subsystem for Linux recently and it’s a really cool concept. Most software I want is not a problem but there are some that are in Snap or Flatpak format.

I am having lots of trouble getting these to work. I’ve read something about systemd not working but some have got it working, I can’t get my head around it. Can someone point me in the right direction?

There is this script on Github that might help you:

Although when I tried it myself with Ubuntu 22.04 I just couldn’t get it to work. The distro just would not start after running it. Maybe you will have better luck with it.


If you don’t have any luck with the above, trying using the Fedora release in the Windows store instead.
There was an issue about it on their Github but it seems to be fully supported and easy to implement.

Have not tried it myself yet.

1 Like

Thanks Nick, I am going to give this a try tonight. If I can’t manage it, I will try your suggestion @keenbot.

I have been looking and asking around and no one seems to have a clear-cut answer for this.


I have tried both suggestions as well as another I had found and nothing seems to have helped.

I suppose it is time to move on from this for the time being. If anyone here happens to see anything online about this, feel free to post about it. Anything helpful.