Switching over a laptop and running into issues

I am trying to boot into Fedora on my laptop but it is refusing to boot into anything other than Windows. I have tried a few different ones to make sure it wasn’t an issue with Fedora but it still isn’t taking. When I boot from the USB, I just get a blank screen. Not sure what to do about this.

Possibly a boot loader issue. I mean that is what I would guess. Another issue could be the drivers. It might be running fine but the screen is not actually showing anything. Have you tried using a different USB or wiping the one you used?

1 Like

Are you dual booting or trying to boot from USB to try Linux (live)? Like Reese said, probably bootloader issues. Try a newer version of Rufus


+1. Follow what they both said. Also check out:

Or you can do this manually with dd command. But another time for that. Sometimes only as a last resort.

1 Like

If it isn’t a bootloader issue, I would guess it is down to your drivers. I would make sure those are updated on the Windows side and then see if that fixes the issue.

Yeah this is what I am thinking. I couldn’t seem to find an issue anywhere so it would make sense for it to be bootloader issues. The drivers are up to date as far as I know.

As for trying a different USB or wiping the same one, I have done both and still have the same issue.